Iridium SBD MO Messaging Delays
Incident Report for Global Alerting Platform (GAP)
Resolved
Iridium has advised that this issue has now been resolved.
Posted Apr 12, 2018 - 14:12 UTC
Identified
We have been advised by Iridium that there is currently an issue affecting Short Burst Data (SBD) mobile originated (MO) messaging. Iridium are working to resolve the problem as quickly as possible.

If your device relies upon the Iridium bearer, messages sent from such devices to the Portal may be affected.
Posted Apr 12, 2018 - 12:24 UTC